Jump to content

Recommended Posts

Well, I might have to change my username. Because after a year of obsessive searching, I finally purchased a 1977 Chinook pop top!!

Actually a friend of mine on the west coast purchased it for me in April, and in about 3 weeks I’m going to go pick it up and drive it 2,400 miles back from California to Georgia.

My friend has test driven the vehicle, and the word from him and the guy I bought it from is that the Chinook is in great mechanical shape except for idling way too high. (My friend reported he had to ride the brakes a lot, and that after a couple hours of city driving the engine was on the verge of overheating.)

(Ironically, there is another ’77 for sale in California right now with a similar problem.)

The previous owner blamed the high idle on the carburetor, which had already been converted to a Weber (I'm assuming 32/36, but I'm not sure) before he bought it. My goal is to get this camper on the road and back home ASAP. Therefore, I’ve been planning to buy a new Weber 32/36, bring it with me to California, and swap it with the old carb as soon as I get out there.

But before I buy the new carb, I thought I should ask a few questions of folks here.

1.) Could anything else be causing the high idling besides the carb? (The engine was supposedly rebuilt recently... Some Weber distributors recommend adding a fuel pressure regulator... Aside from those possibilities, I don't know what else it could be.)

2.) The easier it is to install the new Weber, the better. So when it comes to deciding between an electric or manual choke, I figured I’d just go with the same set up it has now – I just need to find out what that is. Can I tell which choke it has now from photos my friend can take of the carb? What should I be looking for?

3.) If the Weber that's in the camper now turns out to be a 38/38 will I have any problems switching to a 32/36?

Aside from that, any other advice (well, aside from telling me to bring bus fare with me as a fallback plan.. ;) ) is greatly appreciated!

I've attached a couple pics of my new ride. I should have more from my friend soon.

post-7556-0-69867600-1401042000_thumb.jp

post-7556-0-46057700-1401042041_thumb.jp

post-7556-0-59588100-1401042054_thumb.jp

post-7556-0-91221500-1401042341_thumb.jp

post-7556-0-86575100-1401042360_thumb.jp

post-7556-0-99892500-1401042386_thumb.jp

Link to post
Share on other sites

Manual choke carb will have 2 cables going to it. Electric choke will have wires running to carb. Here's a picture of an 'electric choke' carb that should be similar:

http://images.thesamba.com/vw/gallery/pix/316306.jpg

BTW, there's also a water choke version available:

http://www2.izook.com/images/chokeassycaptioned.jpg

Link to post
Share on other sites

Thanks Derek! But I think part of your second sentence got cut off.

You wrote: "Here's a picture of a hoke carb..."

So is that first link a picture of a carb with the manual or the electric choke?

I don't recognize any cables or wires in the photo. But I don't have a lot of experience with carbs, so that could be part of my problem.

Link to post
Share on other sites

Yes, you're right. The picture is the 'electric choke' version with connections for the wires shown. I'll edit my post to correct. I really need to learn to touch type! Maybe in my next lifetime! :)

Remove the air filter and if both chokes/barrels are the same size, it's a 38/38 'Bandit' carb. If they're different, it's a 32/36.

Link to post
Share on other sites

Manual choke has one cable going to it.

High idle could be all sorts of things. Could be the carb is out of adjustment, could be the carb (or other components of the emissions system) has a vacuum leak (very possible if they used the Weber two piece adapter...known for leaks), the timing could be way too far advanced.

I would absolutely NOT buy a new carb before finding out what it is. Even if it IS the carb causing the high idle, you ADJUST carbs, you don't just replace them because they're out of tune.

Not unless it's total junk and ready for a rebuild. But you won't know that till you get it.

Among a lot of other things which could be causing it to overheat, a very lean mixture (which is a carb issue) could be to blame.

It would be terrible if this thing overheated, because it'll need a new head gasket, if not engine rebuild, if it does. These engines don't take kindly to overheating.

But anyway...Congratulations! I hope everything is a simple fix and you enjoy the new toy! It looks pretty nice.

Carb adjustments on Webers are pretty simple. Two screws.

Link to post
Share on other sites

Thanks for those videos, Derek! And for the advice MontanaChinook -- speaking of which...

Since you mentioned the possibility of a vacuum leak, I just remembered: the seller told me that all the smog equipment had been removed. I wonder if a vacuum leak could have been created in the process?

Hopefully I'll know more after my friend sends me some pics of everything that's under the hood.

Also, I'm pretty sure my Chinook has the 20R engine, but I should soon find that out for sure, too.

Link to post
Share on other sites

Not one from the gas pedal and another to the choke knob? Or is the 22R rod operated?

http://nebula.wsimg.com/695225f059b3ecf8b1b05156edfac961?AccessKeyId=1BCC5713D09EAE2BF373&disposition=0&alloworigin=1

You would, in 90% of the situations, be right, and after I posted and was back driving down the road I realized what you meant.

But yeah, on the 20R, at least the pre-79 ones, it's an actual rod. I don't have the time to photoshop an arrow in right now...but you can see the rod going up the right side of the screen.

post-6535-0-71169800-1401069697_thumb.jp

And here you can see the choke linkage. This is looking at the side of the carb from the passenger side. Linkage and cable are right under the air filter, going to the left. And the last photo is the best tell-tale sign of a manual choke :) Right under the speedometer, with an image of the choke on the knob.

post-6535-0-88768200-1401069795_thumb.jp

post-6535-0-20775200-1401069879_thumb.jp

Link to post
Share on other sites

It's possible they didn't plug something off right when they de-smogged it. Who knows. But the Weber two-piece adapter is notorious for leaking. There is a replacement, and if you get to that point let me know and I'll show you what I used. Everybody uses the LC Engineering "spiral" adapter, but it only works for 22R and 22RE engines, not 20R.

Link to post
Share on other sites

Thanks, MontanaChinook! I now feel pretty confident I'll be able to tell which kind of choke I've got.

(And by the way, I remember checking out your build thread a while back. That's a great looking Newport / Omega you've got! And easy to spot with the blue accent.)

Just so it doesn't slip my mind later, would you mind telling me about that replacement adapter?

Link to post
Share on other sites

Though I find some of his level of knowledgeable, the 2nd YouTube I posted before has some maybe very useful info about adjusting the Weber that might hold the key to why the OP Toyota revs so high. Though likely adjusted pretty well from the Factory, who knows who has changed what in the meantime. I'd certainly take it to a Weber specialist before buying a new carb. :)

Link to post
Share on other sites

Looking for a vacuum leak? Use a can of carb cleaner. Carefully spray around the carb base and suspect hoses. If there is a leak the rpm will change, some times faster, some times slower. Stop spraying when the engine gets hot.

Link to post
Share on other sites

Webers are super easy to tune. "Tuned from the factory" doesn't even come into it. The instructions for installation start by telling you to bottom out the adjustments then go from there. So basically there is no factory adjustment, you are meant to adjust it when you install it. The only "factory setting" is the jets, which will (I've been told) always be for sea level. If you're above that, or if, after following the adjustment guidelines you find it calls for different jets, then you order the appropriate jets.

They aren't meant to be "plug and play", they're meant to be tuned by the end user.

Link to post
Share on other sites

Cool. I really appreciate these responses from you guys. I'll look into this further, and let you know if I have any other questions. If not, I'll let you know how it goes out in Cali.

Link to post
Share on other sites
  • 4 weeks later...

Hey everybody. My friend never sent me pics, but I'm in CA with my Chinook now. It has an electric choke and a cheaper weber knock off carb that some shop's paperwork I found in the glovebox said needed a rebuilt. So after trying to adjust it and check for vacuum leaks, all to no avail, I'm now in the process of replacing with a genuine weber.

Looks like it's also going to need a new master cylinder. The fluid reservoir closest to the firewall was bone dry & there was lots of built up gunk underneath it. Going to add fluid today and see if and where it leaks out, but this is what it looks like is happening.

Also, the shop paperwork said there is an exhaust leak at the manifold - a common problem, I know. Since I'm not at home with my tools and work space (and have a 2,500 mile journey ahead of me), I'm going to take my camper to a shop for the brake work and maybe the manifold too.

But first I was wondering: Could the manifold leak cause the engine to overheat or cause any other problems besides the fumes?

Link to post
Share on other sites

Hopefully not...I've driven 10,000 miles in the last 3 months with a manifold leak! Other than being more loud than I'd like when I drive around, I haven't noticed issues...but I hope I'm not messing up the exhaust valves or anything...

Link to post
Share on other sites

Success! Or at least major progress.

I replaced the carb & was able to adjust it to idle properly. And the brake fluid I added didn't leak out after lots of pumping the pedal & driving around for about 90 minutes as I got the hang of the manual trans. (My first one of those, by the way. Got some pointers back when I was 17, then took a class last week. So I still need some practice.)

Still gonna take it to a shop tomorrow before I make the big drive back home.

Link to post
Share on other sites

the stock 20r never had an ext gasket only the metal carb heater box . felpro came out with an aftermarket gasket set also the early manifolds were very prone to cracking. many years ago I payed 150 dollars for a replacement factory redesigned Toyota 20r manifold they crack length wise on the center of the outside in the middle also the flange donuts will burenout . both of my current 22res have issues

Link to post
Share on other sites

The only way I've been able to stop the problems with the exhaust donuts blowing out, was to replace the manifold gasket at the same time.

Just leave the manifold lose, and tighten the flange bolts first. Get the flange tight and make sure that its equally spaced all the way around. Then tighten the manifold.

Link to post
Share on other sites

Glad to hear you've resolved some of the issues. When do you leave for home? I hope you do a full trip report for us Chinook/omega owners. :-)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...