Jump to content

1977 Pont-X -Turn signals and hazards are out


Recommended Posts

I've got a 77 Pont-X (if you look them up, mine will be in most of the pictures), the turn signals and hazards just stopped working. Fuses seem to be OK, high beams work fine, so I don't think it's the lever switch on the column. Someone mentioned it might be some other circuit in the column, but I think it could be the relay. Any thoughts?

Link to comment
Share on other sites

if you have that big four way flasher knob on the dash. pump it on and off a few times and see if that fixes it . i am serious corrision or dirt builds up on the four way switch it normaly never gets used much. this was a problem with the 7os trucks and campers. and when this happens the turn and fourway quit working.  my 78 shortbox truck my 78 motor home . i had this happen

Link to comment
Share on other sites

Thanks for the reply and tip! It ended up that I just had a wire that had come off of my flasher. Everything was/is still fully functional, just got disconnected. Learning all of this as I go and trying to get this thing back into true, reliable form again. Now I know what a flasher looks like lol. Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...