Jump to content

Recommended Posts

seems no matter what I do this belt wont tighten up enough..I changed it recently with what the auto parts shop gave me, tightened as per proper procedure and now after a few thousand miles it seems stretched somehow???..the pump butts up against the engine and does not allow me to tighten the adjustment further???? I am wondering it I can get a slightly smaller belt??? any ideas????............THANKS

Link to post
Share on other sites

Had this same, ongoing problem, using a non OEM belt on my V6 Warrior. The auto parts stores tend to have close-enough belt options that aren’t always... close enough. 
 

I did some careful measurements and then picked up a Duralast 17480 v-belt from AutoZone: it’s a great fit and can be properly tightened. 

Link to post
Share on other sites

I thought I would avoid fitment issues and went with the actual toyota part "Toyota 90916-02196 V-Belt"  lol....which is the one I am having the issues with now....

 

 

Edited by LittleShack
Link to post
Share on other sites

This rings a bell,  someone, not me was having an issue with the V6 PS pump belt. I would never miss something that simple!     One of those you gotta be kidding me moments and hope no one was looking. 

 

 

Try moving the pump away from the block,  I think that was it?? 

Link to post
Share on other sites

thanks for the ideas....the belt is marked with toyota and the part # and moving the pump away further loosens the belt but again thx for the input...all i can think of is a smaller size belt  but even a wider one would help

Link to post
Share on other sites

Is there a fan belt routing decal on the hood? May be you have the belt misrouted. Every thing I've worked on there is ether a separate tension adjuster or the pump, alternator, ac compressor moves away from the engine.

 

Link to post
Share on other sites

Remove the belt measure the full size all the way around yeah it's a little hard I usually cut them and measure go to the parts store and buy one an inch shorter the belt numbers should match the length.

Link to post
Share on other sites
On 9/16/2020 at 9:52 PM, LittleShack said:

thanks for the ideas....the belt is marked with toyota and the part # and moving the pump away further loosens the belt but again thx for the input...all i can think of is a smaller size belt  but even a wider one would help

Darn your right!   second time in this century I have been wrong.    I had to push the pump away from the block to get the new belt on!   Went through a few belts.  Now have a NAPA Premium XL  25-9480 that fit.  Not a lot of adjustment there, almost like the pump pulley is the wrong size!

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...